University of Central Florida

Status
Dashboard

What’s up, or down? The UCF Services Status Health Dashboard displays a real-time view of services that are working or possible current outages. Contact the UCF Support Center at 407-823-5117 for assistance or information about this site.

[POWER] Power Outage Due to Blown Transformer
Incident Report for UCF Service
Resolved
A blown electrical transformer affected multiple buildings in the north area of campus. This also impacted UCF service at SSC in Sanford. The majority of affected buildings recovered once power was restored earlier today. Several outlying issues took longer to resolve. At this time, UCF IT has verified all affected buildings are back online.
Posted Aug 15, 2022 - 16:16 EDT
Update
WHAT IS HAPPENING?
Power outage has occurred affecting mainly the north area of campus.

WHO IS IMPACTED?
Lake Claire Apartments, Greek Park, HEC, Arena, Parking Garage D, South Cell Tower, District Energy Plant. SSC Sanford was also impacted.

WHAT ARE WE DOING ABOUT IT?
Network Services is still troubleshooting affected devices in the Arena.

WHAT HAPPENS NEXT?
Next update will be at 4PM.

WHAT DO I NEED TO DO?
Check back for additional updates.
Posted Aug 15, 2022 - 15:03 EDT
Update
WHAT IS HAPPENING?
Power outage has occurred affecting mainly the north area of campus.

WHO IS IMPACTED?
Lake Claire Apartments, Greek Park, HEC, Arena, Parking Garage D, South Cell Tower, District Energy Plant. SSC Sanford was also impacted.

WHAT ARE WE DOING ABOUT IT?
Power has been restored and UCF IT is monitoring. Network Services is still troubleshooting affected devices in the Arena. All other affected buildings are back online.

WHAT HAPPENS NEXT?
Next update will be at 2PM.

WHAT DO I NEED TO DO?
Check back for additional updates.
Posted Aug 15, 2022 - 12:16 EDT
Update
WHAT IS HAPPENING?
Power outage has occurred affecting mainly the north area of campus.

WHO IS IMPACTED?
Lake Claire Apartments, Greek Park, HEC, Arena, Parking Garage D, South Cell Tower, District Energy Plant. SSC Sanford was also impacted.

WHAT ARE WE DOING ABOUT IT?
Power has been restored and UCF IT is monitoring. Network Services is investigating residual affected devices in the Arena and GP415. All other affected buildings are back online.

WHAT HAPPENS NEXT?
Next update will be at noon.

WHAT DO I NEED TO DO?
Check back for additional updates.
Posted Aug 15, 2022 - 10:53 EDT
Investigating
WHAT IS HAPPENING?
Power outage has occurred affecting mainly the north area of campus.

WHO IS IMPACTED?
Lake Claire Apartments, Greek Park, HEC, Arena, Parking Garage D, South Cell Tower, District Energy Plant.

WHAT ARE WE DOING ABOUT IT?
We are currently investigating this issue. Work Control and Duke Energy have been notified

WHAT HAPPENS NEXT?
Updated will be sent out hourly starting at 10:30AM.

WHAT DO I NEED TO DO?
Check back for additional updates.
Posted Aug 15, 2022 - 09:38 EDT
This incident affected: Network & Connectivity (Campus Internet).