University of Central Florida

Status
Dashboard

What’s up, or down? The UCF Services Status Health Dashboard displays a real-time view of services that are working or possible current outages. Contact the UCF Support Center at 407-823-5117 for assistance or information about this site.

Inbound/Outbound Teams Calling Failures

Incident Report for UCF Service

Resolved

Telephony services to Microsoft Teams and AudioCodes Voca Contact Center were restored at 12:30pm on 7/16/2026. We monitored for 24 hours, and no additional disruptions were observed.
Posted Jul 17, 2026 - 15:34 EDT

Update

WHAT IS HAPPENING?
External Teams Calling was experiencing failues for both inbound and outbound calls.

WHO IS IMPACTED?
This impacts all employee's who may be utilizing Teams for External calling.

WHAT ARE WE DOING ABOUT IT?
A fix has been implemented, and successful calls are being routed. We are continuing to monitor and resolve the situation.

WHAT HAPPENS NEXT?
We will provide additional updates as we have them.

WHAT DO I NEED TO DO?
If you are still experiencing Teams Calling Failures, contact the Service Desk at 407-823-5117, or submit an a ticket at https://it.ucf.edu/ with details regarding the failed calls.
Posted Jul 16, 2026 - 12:36 EDT

Investigating

WHAT IS HAPPENING?
External Teams Calling is currently failing for both inbound and outbound calls.

WHO IS IMPACTED?
This impacts all employee's who may be utilizing Teams for External calling.

WHAT ARE WE DOING ABOUT IT?
We are currently investigating this issue.
Posted Jul 16, 2026 - 12:17 EDT
This incident affected: Conferencing & Telephones (Teams Calling).