University of Central Florida

Status
Dashboard

What’s up, or down? The UCF Services Status Health Dashboard displays a real-time view of services that are working or possible current outages. Contact the UCF Support Center at 407-823-5117 for assistance or information about this site.

Spectrum Services Degraded - Main Campus
Incident Report for UCF Service
Resolved
A planned power outage on campus impacted Spectrum's equipment. Generators were brought on-site in order to maintain cable TV service until the planned power outage was complete.
Posted Jan 02, 2024 - 13:32 EST
Update
WHAT IS HAPPENING?
Spectrum is reporting degraded service across Main Campus due to hardware failure.

WHO IS IMPACTED?
Spectrum service customers on Main Campus.

WHAT ARE WE DOING ABOUT IT?
UCF IT is seeing improvements in service across campus and will continue to monitor.

WHAT HAPPENS NEXT?
Additional updates will be provided until issue is resolved.

WHAT DO I NEED TO DO?
Check back for further updates.
Posted Dec 19, 2023 - 17:42 EST
Investigating
WHAT IS HAPPENING?
Spectrum is reporting degraded service across Main Campus due to hardware failure.

WHO IS IMPACTED?
Spectrum service customers on Main Campus.

WHAT ARE WE DOING ABOUT IT?
Spectrum technicians are on-site troubleshooting.

WHAT HAPPENS NEXT?
Additional updates will be provided until issue is resolved.

WHAT DO I NEED TO DO?
Check back for further updates.
Posted Dec 19, 2023 - 14:47 EST
This incident affected: Network & Connectivity (CATV).