University of Central Florida

Status
Dashboard

What’s up, or down? The UCF Services Status Health Dashboard displays a real-time view of services that are working or possible current outages. Contact the UCF Support Center at 407-823-5117 for assistance or information about this site.

Service Interruption: Issue impacting some integrated tools (including but not limited to Respondus LockDown Browser) in Webcourses@UCF [Monitoring]

Incident Report for UCF Service

Update

WHAT IS HAPPENING?
Webcourses@UCF Support continues to monitor an issue impacting some integrated tools within Webcourses@UCF. At this time, the tools that were previously reported as impacted appear to be functioning as expected. We have not received any new confirmed reports of user‑facing issues.

WHO IS IMPACTED?
Instructors/Faculty/Students

WHAT ARE WE DOING ABOUT IT?
We are actively monitoring the situation and continuing to review reports related to impacted tools. Our team will provide updates as needed if there are any changes to the status.

WHAT HAPPENS NEXT?
We will continue to monitor the situation and review any additional reports related to impacted tools. Updates will be provided if there are any changes to the status.

WHAT DO I NEED TO DO?
No actions are currently required. We appreciate your patience while we continue to monitor the issue. If you are experiencing an issue within Webcourses@UCF or have information that may help with our investigation, please contact Webcourses@UCF Support at https://cdl.ucf.edu/support/webcourses/contact.

For the latest updates, please visit UCF's Status Dashboard at https://status.ucf.edu/.
Posted May 06, 2026 - 15:56 EDT

Update

WHAT IS HAPPENING?
Webcourses@UCF Support continues to monitor an issue impacting some integrated tools within Webcourses@UCF. At this time, the tools that were previously reported as impacted appear to be functioning as expected. We have not received any new confirmed reports of user‑facing issues.

WHO IS IMPACTED?
Instructors/Faculty/Students

WHAT ARE WE DOING ABOUT IT?
We are actively monitoring the situation and continuing to review reports related to impacted tools. Our team will provide updates as needed if there are any changes to the status.

WHAT HAPPENS NEXT?
We will continue to monitor the situation and review any additional reports related to impacted tools. Updates will be provided if there are any changes to the status.

WHAT DO I NEED TO DO?
No actions are currently required. We appreciate your patience while we continue to monitor the issue. If you are experiencing an issue within Webcourses@UCF or have information that may help with our investigation, please contact Webcourses@UCF Support at https://cdl.ucf.edu/support/webcourses/contact.

For the latest updates, please visit UCF's Status Dashboard at https://status.ucf.edu/.
Posted May 05, 2026 - 15:54 EDT

Update

WHAT IS HAPPENING?
Webcourses@UCF Support is monitoring an issue impacting some integrated tools within Webcourses@UCF. At this time, we have confirmed reports that some users are experiencing issues accessing Simple Syllabus, Honorlock, LockDown Browser (LDB), and Panopto videos. Other integrated tools may also be experiencing issues.

WHO IS IMPACTED?
Instructors/Faculty/Students

WHAT ARE WE DOING ABOUT IT?
We are actively monitoring the situation and continuing to review reports related to impacted tools. Our team will provide updates as needed if there are any changes to the status.

WHAT HAPPENS NEXT?
We will continue to monitor the situation and review any additional reports related to impacted tools. Updates will be provided if there are any changes to the status.

WHAT DO I NEED TO DO?
No actions are currently required. We appreciate your patience while we continue to monitor the issue. If you are experiencing an issue within Webcourses@UCF or have information that may help with our investigation, please contact Webcourses@UCF Support at https://cdl.ucf.edu/support/webcourses/contact.

For the latest updates, please visit UCF's Status Dashboard at https://status.ucf.edu/.
Posted May 04, 2026 - 17:34 EDT

Monitoring

WHAT IS HAPPENING?
Webcourses@UCF Support is monitoring an issue impacting some integrated tools within Webcourses@UCF. At this time, we have confirmed reports that some students are experiencing issues accessing Panopto videos. Other integrated tools may still be experiencing issues.

WHO IS IMPACTED?
Instructors/Faculty/Students

WHAT ARE WE DOING ABOUT IT?
We are actively monitoring the situation and continuing to review reports related to impacted tools. Our team will provide updates as needed if there are any changes to the status.

WHAT HAPPENS NEXT?
We will continue to monitor the situation and review any additional reports related to impacted tools. Updates will be provided if there are any changes to the status.

WHAT DO I NEED TO DO?
No actions are currently required. We appreciate your patience while we continue to monitor the issue. If you are experiencing an issue within Webcourses@UCF or have information that may help with our investigation, please contact Webcourses@UCF Support at https://cdl.ucf.edu/support/webcourses/contact.

For the latest updates, please visit UCF's Status Dashboard at https://status.ucf.edu/.
Posted May 03, 2026 - 19:50 EDT

Update

WHAT IS HAPPENING?
Webcourses@UCF Support is still investigating an issue impacting some integrated tools within Webcourses@UCF. At this time, we have confirmed reports that some students are experiencing issues accessing Panopto videos. Other integrated tools may still be affected, and our team continues to monitor for additional reports.

WHO IS IMPACTED?
Instructors/Faculty

WHAT ARE WE DOING ABOUT IT?
We are actively investigating the issue and working with the appropriate vendor as needed to restore service as quickly as possible.

WHAT HAPPENS NEXT?
We will continue to monitor the situation and will provide updates as more information becomes available.

WHAT DO I NEED TO DO?
No actions are currently required. We appreciate your patience while we work to resolve this issue. If you have information that may help with our investigation, please contact Webcourses@UCF Support at https://cdl.ucf.edu/support/webcourses/contact.

For the latest updates, please visit UCF's Status Dashboard at https://status.ucf.edu/.
Posted May 02, 2026 - 17:37 EDT

Update

WHAT IS HAPPENING?
Webcourses@UCF Support is still investigating an issue impacting some integrated tools within Webcourses@UCF. At this time, we have confirmed that faculty should now have full access to the LockDown Browser (LDB) dashboard and be able to configure LDB for their assessments. Other integrated tools may still be experiencing issues.

WHO IS IMPACTED?
Instructors/Faculty

WHAT ARE WE DOING ABOUT IT?
We are actively investigating the issue and working with the appropriate vendor as needed to restore service as quickly as possible.

WHAT HAPPENS NEXT?
We will continue to monitor the situation and will provide updates as more information becomes available.

WHAT DO I NEED TO DO?
No actions are currently required. We appreciate your patience while we work to resolve this issue. If you have information that may help with our investigation, please contact Webcourses@UCF Support at https://cdl.ucf.edu/support/webcourses/contact.

For the latest updates, please visit UCF's Status Dashboard at https://status.ucf.edu/.
Posted May 01, 2026 - 15:37 EDT

Investigating

WHAT IS HAPPENING?
Webcourses@UCF Support is currently investigating an issue impacting some integrated tools within Webcourses@UCF, which began at 7 PM ET on April 30th. At this time, we have confirmed that some faculty are unable to access the LockDown Browser (LDB) dashboard or configure LDB for their assessments. There is no known impact to students at this time.

WHO IS IMPACTED?
Instructors/Faculty

WHAT ARE WE DOING ABOUT IT?
We are actively investigating the issue and working with the appropriate vendor as needed to restore service as quickly as possible.

WHAT DO I NEED TO DO?
No actions are currently required. We appreciate your patience while we work to resolve this issue. If you have information that may help with our investigation, please contact Webcourses@UCF Support at https://cdl.ucf.edu/support/webcourses/contact.

For the latest updates, please visit UCF's Status Dashboard at https://status.ucf.edu/.
Posted May 01, 2026 - 09:16 EDT
This incident affects: Learning Management Systems (Webcourses).