What’s up, or down? The UCF Services Status Health Dashboard displays a real-time view of services that are working or possible current outages. Contact the UCF Support Center at 407-823-5117 for assistance or information about this site.
UCF experienced temporary disruptions to call routing and some Microsoft 365 services due to a Microsoft cloud infrastructure issue. Microsoft resolved the issue and services have been restored. We appreciate your patience while the vendor worked to restore service.
Posted Jul 24, 2026 - 10:11 EDT
Update
WHAT IS HAPPENING? Microsoft has reported that their issues are resolved The impacted services from earlier today included: Teams - Images and Files, Power Platform, and our Contact Center solution is unable to route inbound calls to available agents. We will monitor our systems for any new issues and close this problem on Friday July 24tth if all MIcrosoft services remain normal.
WHO IS IMPACTED? UCF and other customers of this service are impacted.
WHAT ARE WE DOING ABOUT IT? The service disruption affecting VOCA has been resolved, and services have returned to normal operation. Microsoft 365 services update: We've completed reverting the networking update, and our telemetry indicates impact is resolved for the vast majority of users. We're reviewing all known impact scenarios and monitoring for a period of time to confirm resolution for all affected environments.
WHAT HAPPENS NEXT? UCF will monitor the services and report to Microsoft and/or VOCA if problems re-appear.
WHAT DO I NEED TO DO? Use email if possible to reach a UCF office today and stay updated.
Posted Jul 23, 2026 - 16:48 EDT
Update
WHAT IS HAPPENING? Inbound phone calls to UCF are not being routed to available agents (staff).
WHO IS IMPACTED? UCF and other customers of this service are impacted. At this time, all inbound calls are not being properly routed and our customers will not reach a staff member. Any department using the VOCA Content Center service is impacted.
WHAT ARE WE DOING ABOUT IT? We have opened a support case with our Contact Center provider.
WHAT HAPPENS NEXT? UCF will monitor the Contract Center's updates.
WHAT DO I NEED TO DO? Use email if possible to reach a UCF office today and stay updated.
Posted Jul 23, 2026 - 15:32 EDT
Update
WHAT IS HAPPENING? Inbound phone calls to UCF are not being routed to available agents (staff).
WHO IS IMPACTED? UCF and other customers of this service are impacted. At this time, all inbound calls are not being properly routed and our customers will not reach a staff member. Any department using the VOCA Content Center service is impacted.
WHAT ARE WE DOING ABOUT IT? We have opened a support case with our Contact Center provider.
WHAT HAPPENS NEXT? UCF will monitor the Contract Center's updates.
WHAT DO I NEED TO DO? Use email if possible to reach a UCF office today and stay updated.
Posted Jul 23, 2026 - 13:47 EDT
Update
WHAT IS HAPPENING? Inbound phone calls to UCF are not being routed to available agents (staff).
WHO IS IMPACTED? UCF and other customers of this service are impacted. At this time, all inbound calls are not being properly routed and our customers will not reach a staff member. Any department using the VOCA Content Center service is impacted.
WHAT ARE WE DOING ABOUT IT? We have opened a support case with our Contact Center provider.
WHAT HAPPENS NEXT? UCF will monitor the Contract Center's updates.
WHAT DO I NEED TO DO? Use email if possible to reach a UCF office today and stay updated.
Posted Jul 23, 2026 - 12:42 EDT
Investigating
WHAT IS HAPPENING? Inbound phone calls to UCF are not being routed to available agents (staff).
WHO IS IMPACTED? UCF and other customers of this service are impacted. At this time, all inbound calls are not being properly routed and our customers will not reach a staff member. Any department using the VOCA Content Center service is impacted.
WHAT ARE WE DOING ABOUT IT? We have opened a support case with our Contact Center provider.
WHAT HAPPENS NEXT? UCF will monitor the Contract Center's updates.
WHAT DO I NEED TO DO? Use email if possible to reach a UCF office today and stay updated.
Posted Jul 23, 2026 - 11:55 EDT
This incident affected: Conferencing & Telephones (Contact Center (Hosted by VOCA)).