University of Central Florida

Status
Dashboard

What’s up, or down? The UCF Services Status Health Dashboard displays a real-time view of services that are working or possible current outages. Contact the UCF Support Center at 407-823-5117 for assistance or information about this site.

Workday is currently experiencing intermittent performance issues.

Incident Report for UCF Service

Resolved

Workday has restored service to all of their affected data centers. UCF Employees should now be able to login to workday.ucf.edu.
Posted Mar 17, 2025 - 16:13 EDT

Investigating

WHAT IS HAPPENING?
Workday is currently experiencing intermittent performance issues.

WHO IS IMPACTED?
Faculty and staff who use Workday for HR and Finance business processes.

WHAT ARE WE DOING ABOUT IT?
We are currently investigating this issue with Workday.

WHAT HAPPENS NEXT?
The UCF Workday Enterprise Systems team will continue to work with Workday until the issue is resolved.

WHAT DO I NEED TO DO?
Please continue to check the status.ucf.edu page and further communications will be sent as we work through this issue with Workday.
Posted Mar 17, 2025 - 14:43 EDT
This incident affected: ERP Cloud Systems (Workday (Faculty & Staff)).