University of Central Florida

Status
Dashboard

What’s up, or down? The UCF Services Status Health Dashboard displays a real-time view of services that are working or possible current outages. Contact the UCF Support Center at 407-823-5117 for assistance or information about this site.

The network at Hercules 109, 110, and the Academic Villages Mail Center are offline

Incident Report for UCF Service

Resolved

HERCULES 109, 110, and the Academic Villages Mail Center are all back online.
Posted Aug 22, 2026 - 02:25 EDT

Update

WHAT IS HAPPENING?
Network connectivity is offline for both wired and wireless.

WHO IS IMPACTED?
Students and staff at Hercules 109, 110, and the Academic Villages Mail Center currently do not have network connectivity.

WHAT ARE WE DOING ABOUT IT?
HERCULES 109 has been restored, all active alarms have cleard.
Engineers continue to investigate HERCULES 110 and the Academic Villages Mail Center.

WHAT HAPPENS NEXT?
We will provide another update in 30-min.

WHAT DO I NEED TO DO?
For students and staff there are no furhter actions required.
Posted Aug 22, 2026 - 01:48 EDT

Update

WHAT IS HAPPENING?
Network connectivity is offline for both wired and wireless.

WHO IS IMPACTED?
Students and staff at Hercules 109, 110, and the Academic Villages Mail Center currently do not have network connectivity.

WHAT ARE WE DOING ABOUT IT?
Engineers have identified a root cause, restoration efforts continue.

WHAT HAPPENS NEXT?
We will provide another update in 30-min.

WHAT DO I NEED TO DO?
For students and staff there are no furhter actions required.
Posted Aug 22, 2026 - 01:07 EDT

Update

WHAT IS HAPPENING?
Network connectivity is offline for both wired and wireless.

WHO IS IMPACTED?
Students and staff at Hercules 109, 110, and the Academic Villages Mail Center currently do not have network connectivity.

WHAT ARE WE DOING ABOUT IT?
Engineers remain engaged and are actively investigating and working towards a solution.

WHAT HAPPENS NEXT?
We will provide another update in 60-min.

WHAT DO I NEED TO DO?
For students and staff there are no furhter actions required.
Posted Aug 22, 2026 - 00:30 EDT

Update

WHAT IS HAPPENING?
Network connectivity is offline for both wired and wireless.

WHO IS IMPACTED?
Students and staff at Hercules 109, 110, and the Academic Villages Mail Center currently do not have network connectivity.

WHAT ARE WE DOING ABOUT IT?
Engineers remain engaged and are actively investigating and working towards a solution.

WHAT HAPPENS NEXT?
We will provide another update in 30-min.

WHAT DO I NEED TO DO?
For students and staff there are no furhter actions required.
Posted Aug 21, 2026 - 23:25 EDT

Update

WHAT IS HAPPENING?
Network connectivity is offline for both wired and wireless.

WHO IS IMPACTED?
Students and staff at Hercules 109, 110, and the Academic Villages Mail Center currently do not have network connectivity.

WHAT ARE WE DOING ABOUT IT?
Engineers remain engaged and are investigating this issue.

WHAT HAPPENS NEXT?
We will provide another update in 30-min.

WHAT DO I NEED TO DO?
For students and staff there are no furhter actions required.
Posted Aug 21, 2026 - 20:00 EDT

Update

WHAT IS HAPPENING?
Network connectivity is offline for both wired and wireless.

WHO IS IMPACTED?
Students and staff at Hercules 109, 110, and the Academic Villages Mail Center currently do not have network connectivity.

WHAT ARE WE DOING ABOUT IT?
Another follow-up update, Engineers are still engaged and investigating this issue.

WHAT HAPPENS NEXT?
We will provide another update in 30-min.

WHAT DO I NEED TO DO?
For students and staff there are no furhter actions required.
Posted Aug 21, 2026 - 18:44 EDT

Update

WHAT IS HAPPENING?
Network connectivity is offline for both wired and wireless.

WHO IS IMPACTED?
Students and staff at Hercules 109, 110, and the Academic Villages Mail Center currently do not have network connectivity.

WHAT ARE WE DOING ABOUT IT?
Follow-up update, Engineers are still investigating this issue.

WHAT HAPPENS NEXT?
We will provide another update in 30-min.

WHAT DO I NEED TO DO?
For students and staff there are no furhter actions required.
Posted Aug 21, 2026 - 17:46 EDT

Investigating

WHAT IS HAPPENING?
Network connectivity is offline for both wired and wireless.

WHO IS IMPACTED?
Students and staff at Hercules 109, 110, and the Academic Villages Mail Center currently do not have network connectivity.

WHAT ARE WE DOING ABOUT IT?
We are currently investigating this issue.

WHAT HAPPENS NEXT?
We will provide another update in 30-min.

WHAT DO I NEED TO DO?
For students and staff there are no furhter actions required.
Posted Aug 21, 2026 - 16:55 EDT
This incident affected: Network & Connectivity (Housing Internet).