University of Central Florida

Status
Dashboard

What’s up, or down? The UCF Services Status Health Dashboard displays a real-time view of services that are working or possible current outages. Contact the UCF Support Center at 407-823-5117 for assistance or information about this site.

SMTP Degraded Performance
Incident Report for UCF Service
Resolved
This incident has been resolved.
Posted Feb 21, 2022 - 10:07 EST
Update
What is happening?
We've confirmed after extensive monitoring an issue where applications that utilize UCF's SMTP relay servers for email delivery may experience intermittent service degradation & connection delays for SMTP transactions due to concurrency/recipient limits.

Who is impacted?
Applications, monitoring tools & Customer Relationship Software (CRMs) that utilize UCF's SMTP relay servers to send email and attachments for promotional campaigns, marketing, LEAP requests, NID password resets, UCF custom applications, eFORMs, helpdesk tickets, PeopleSoft, enterprise remote monitoring etc.

What are we doing about it?
We're continuing to work with the vendor to improve performance on the underlying infrastructure and are evaluating additional mitigation options through cloud-based SMTP providers for bulk-email marketing and business critical applications.

What happens next?
The SMTP relay servers are operational at this time but applications utilizing UCF's SMTP relays for email delivery may experience intermittent service degradation issues & connection delays when concurrency & recipient limits are reached.

What do I need to do?
To ensure that your emails reach their destination, we recommend that you use the following practices:
- Ensure your recipient lists are current and accurate.
- Scheduling bulk email or marketing campaigns during non-peak business hours.
- Utilizing group email addresses, or shared mailboxes instead of individualized email addresses for recipients where applicable.
- Increasing the retry timeout interval on renewed SMTP connection attempts.
- Decreasing the 'batch size' of SMTP transactions to send 500 or less emails to be delivered per SMTP session.

For users who are still impacted, we'll continue to provide updates in Service-Now under Problem Record PRB0040809.
Posted Jan 11, 2022 - 09:55 EST
Update
What is happening?
We've confirmed after extensive monitoring an issue where applications that utilize UCF's SMTP relay servers for email delivery may experience intermittent service degradation & connection delays for SMTP transactions due to concurrency/recipient limits.

Who is impacted?
Applications, monitoring tools & Customer Relationship Software (CRMs) that utilize UCF's SMTP relay servers to send email and attachments for promotional campaigns, marketing, LEAP requests, eFORMs, helpdesk tickets, PeopleSoft, enterprise remote monitoring etc.

What are we doing about it?
We're continuing to work with the vendor to improve performance on the underlying infrastructure and are evaluating additional mitigation options through cloud-based SMTP providers for bulk-email marketing and business critical applications.

What happens next?
The SMTP relay servers are operational at this time but applications utilizing UCF's SMTP relays for email delivery may experience intermittent service degradation issues & connection delays when concurrency & recipient limits are reached.

What do I need to do?
To ensure that your emails reach their destination, we recommend that you use the following practices:
- Ensure your recipient lists are current and accurate.
- Scheduling bulk email or marketing campaigns during non-peak business hours.
- Utilizing group email addresses, or shared mailboxes instead of individualized email addresses for recipients where applicable.
- Increasing the retry timeout interval on renewed SMTP connection attempts.

For users who are still impacted, we’ll continue to provide updates in Service-Now under Problem Record PRB0040816.
Posted Jan 03, 2022 - 16:10 EST
Identified
We've confirmed after extensive monitoring an issue where users may experience intermittent connection delays for SMTP transactions due to concurrency/recipient limits. We're continuing to work with the vendor to improve performance on the underlying infrastructure. For users who are still impacted, we’ll continue to provide updates in Service-Now under Problem Record PRB0040816.
Posted Dec 21, 2021 - 23:22 EST
Investigating
We are currently investigating this issue.
Posted Dec 15, 2021 - 11:32 EST
This incident affected: Mass Communications (SMTP).