What’s up, or down? The UCF Services Status Health Dashboard displays a real-time view of services that are working or possible current outages. Contact the UCF Support Center at 407-823-5117 for assistance or information about this site.
Engineers identified an issue with the Wireless LAN Controller (WLC) that supports the Soth-West Region of Main Campus. The WLC was reloaded to restart services, once completed, the APs were able to re-associate successfully and support new client connections.
Posted Jul 27, 2026 - 11:28 EDT
Update
WHAT IS HAPPENING? We've received reports of wireless connectivity being impacted at multiple locations.
WHO IS IMPACTED? Users at UWC, CSB, and Library are reporting that wireless connectivity is unavailable.
WHAT ARE WE DOING ABOUT IT? We've investigated and have identified the root cause.
WHAT HAPPENS NEXT? We are seeing services coming back online and users rejoining, we will continue to monitor.
WHAT DO I NEED TO DO? If you continue to experience any wireless access issues, please reach out to Support Services to submit a ticket.
Posted Jul 27, 2026 - 10:43 EDT
Identified
WHAT IS HAPPENING? We've received reports of wireless connectivity being impacted at multiple locations.
WHO IS IMPACTED? Users at UWC, CSB, and Library are reporting that wireless connectivity is unavailable.
WHAT ARE WE DOING ABOUT IT? We are currently investigating this issue.
WHAT HAPPENS NEXT? Teams are engaged and reporting back, another update will be provided within 1-hour.
WHAT DO I NEED TO DO? If you experience any issues wireless access issues, please reach out to Support Services to submit a ticket.
Posted Jul 27, 2026 - 10:16 EDT
This incident affected: Network & Connectivity (Campus Internet).