University of Central Florida

Status
Dashboard

What’s up, or down? The UCF Services Status Health Dashboard displays a real-time view of services that are working or possible current outages. Contact the UCF Support Center at 407-823-5117 for assistance or information about this site.

Webcourses@UCF is unavailable.

Incident Report for UCF Service

Resolved

This incident has been resolved. You may now safely login to Webcourses.
Posted May 08, 2026 - 11:34 EDT

Investigating

We are currently investigating this issue.
Posted May 07, 2026 - 16:48 EDT
This incident affected: Learning Management Systems (Webcourses).