What’s up, or down? The UCF Services Status Health Dashboard displays a real-time view of services that are working or possible current outages. Contact the UCF Support Center at 407-823-5117 for assistance or information about this site.
Get email notifications whenever UCF Service creates, updates or resolves an incident.
Get text message notifications whenever UCF Service creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
UCF IT has confirmed that inbound calling to UCF phone numbers has remained stable following extended monitoring after yesterday's service interruption related to carrier maintenance.
Posted May 20, 2025 - 11:04 EDT
Monitoring
WHAT IS HAPPENING? The external carrier has restored inbound calling to UCF phone numbers following this morning's outage. The issue was related to overnight carrier maintenance.
WHO IS IMPACTED? All inbound calls to UCF phone numbers were previously affected. Outbound calls and calls to 911 (emergency services) remained operational during the incident.
WHAT ARE WE DOING ABOUT IT? UCF IT is continuing to actively monitor the service to ensure full resolution and stability across all systems.
WHAT HAPPENS NEXT? No action is needed at this time. UCF IT will provide further updates if any issues recur.
WHAT DO I NEED TO DO? For ongoing updates and system status, please visit: status.ucf.edu
Posted May 19, 2025 - 09:24 EDT
Identified
WHAT IS HAPPENING? UCF IT is currently monitoring an outage impacting inbound phone calls to UCF due to external carrier maintenance.
WHO IS IMPACTED? All inbound calls to UCF phone numbers are impacted. Outbound calls and calls to 911 (emergency services) are working normally.
WHAT ARE WE DOING ABOUT IT? We are actively working with the carrier to resolve the issue.
WHAT HAPPENS NEXT? To stay up-to-date, please monitor the service status page: status.ucf.edu.
WHAT DO I NEED TO DO? UCF IT is actively working with the phone carrier to resolve the issue. We will provide updates as they become available.
Posted May 19, 2025 - 07:21 EDT
This incident affected: Conferencing & Telephones (Teams Calling).