University of Central Florida

Status
Dashboard

What’s up, or down? The UCF Services Status Health Dashboard displays a real-time view of services that are working or possible current outages. Contact the UCF Support Center at 407-823-5117 for assistance or information about this site.

ServiceNow Email Issue

Incident Report for UCF Service

Resolved

The issue affecting emails sent from ServiceNow has been fully resolved. All notifications should now be processing and delivering normally.

What this means for you:

Action Required: As a precaution, technicians with open tickets that were last updated between 05/12/2026 @ 6:00 PM and 05/13/2026 @ 1:00 PM, may want to take a moment to review them to ensure any update notifications were not missed.

Thank you for your patience while we worked to restore this service. If you encounter any further issues, please submit a support ticket.
Posted May 13, 2026 - 13:30 EDT

Investigating

WHO IS IMPACTED?
Employees

WHAT ARE WE DOING ABOUT IT?
We are currently investigating this issue.
Posted May 13, 2026 - 11:38 EDT
This incident affected: IT Service Delivery & Support (ServiceNow).