University of Central Florida

Status
Dashboard

What’s up, or down? The UCF Services Status Health Dashboard displays a real-time view of services that are working or possible current outages. Contact the UCF Support Center at 407-823-5117 for assistance or information about this site.

Public web service degradation

Incident Report for UCF Service

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 14:17 EST

Monitoring

Cloudflare has implemented a fix, and services are beginning to stabilize. UCF IT continues to monitor the situation closely to ensure everything returns to normal.
Posted Nov 18, 2025 - 11:02 EST

Investigating

UCF IT is aware of wide-spread disruptions with a major cloud service (Cloudflare) provider which are intermittently disrupting a wide range of services, including ChatGPT and CoPilot. Some UCF services, including Interfolio, are also disrupted by this service outage. UCF IT is monitoring the situation for further developments.
Posted Nov 18, 2025 - 09:28 EST
This incident affected: Web Services (Public cloud services).