University of Central Florida

Status
Dashboard

What’s up, or down? The UCF Services Status Health Dashboard displays a real-time view of services that are working or possible current outages. Contact the UCF Support Center at 407-823-5117 for assistance or information about this site.

QUALTRICS UPDATE: @knights.ucf.edu Email From Addresses no longer working
Incident Report for UCF Service
Resolved
Qualtrics is deprecating non-authenticated email addresses due to Google and Yahoo changing spam filtering rules. Mail.ucf.edu is the "official" UCF from email address to be used for all surveys and workflows.
Posted Jan 19, 2024 - 10:57 EST
Update
WHAT IS HAPPENING?
UPDATE: @knights.ucf.edu email addresses will no longer work with Qualtrics after January 31. Please use @UCF.EDU or @MAIL.UCF.EDU for any email requirements.


Qualtrics is deprecating non-authenticated email addresses due to Google and Yahoo changing spam filtering rules. Mail.ucf.edu is the "official" UCF from email address to be used for all surveys and workflows.

Google and Yahoo aim to reduce the amount of spam emails their users receive and improve email security. To accomplish this, any bulk email sender will be subject to strict new requirements to avoid experiencing email deliverability issues.

Starting February 1, 2024, if a bulk-sending organization has an abuse complaint rate of 0.3% or higher, Google will automatically block all messages from that organization. Yahoo notes their enforcement will begin "in the first quarter of 2024". While Google and Yahoo are leading the way in early 2024, other email providers will likely follow suit.

WHO IS IMPACTED?
All Qualtrics Users

WHAT ARE WE DOING ABOUT IT?
Users will need to change any email addresses to use @mail.ucf.edu or @ucf.edu.

WHAT HAPPENS NEXT?
Users will need to change any email addresses to use @mail.ucf.edu or @ucf.edu.

WHAT DO I NEED TO DO?
Users will need to change any email addresses to use @mail.ucf.edu or @ucf.edu.
Posted Jan 19, 2024 - 09:57 EST
Monitoring
WHAT IS HAPPENING?
UPDATE: @knights.ucf.edu email addresses will no longer work with Qualtrics after January 31. Please use @UCF.EDU or @MAIL.UCF.EDU for any email requirements.


Qualtrics is deprecating non-authenticated email addresses due to Google and Yahoo changing spam filtering rules. Mail.ucf.edu is the "official" UCF from email address to be used for all surveys and workflows.

Google and Yahoo aim to reduce the amount of spam emails their users receive and improve email security. To accomplish this, any bulk email sender will be subject to strict new requirements to avoid experiencing email deliverability issues.

Starting February 1, 2024, if a bulk-sending organization has an abuse complaint rate of 0.3% or higher, Google will automatically block all messages from that organization. Yahoo notes their enforcement will begin "in the first quarter of 2024". While Google and Yahoo are leading the way in early 2024, other email providers will likely follow suit.

WHO IS IMPACTED?
All Qualtrics Users

WHAT ARE WE DOING ABOUT IT?
Users will need to change any email addresses to use @mail.ucf.edu or @ucf.edu.

WHAT HAPPENS NEXT?
Users will need to change any email addresses to use @mail.ucf.edu or @ucf.edu.

WHAT DO I NEED TO DO?
Users will need to change any email addresses to use @mail.ucf.edu or @ucf.edu.
Posted Jan 19, 2024 - 09:55 EST
Update
WHAT IS HAPPENING?
Qualtrics is deprecating non-authenticated email addresses due to Google and Yahoo changing spam filtering rules. Mail.ucf.edu is the "official" UCF from email address to be used for all surveys and workflows.

Google and Yahoo aim to reduce the amount of spam emails their users receive and improve email security. To accomplish this, any bulk email sender will be subject to strict new requirements to avoid experiencing email deliverability issues.

Starting February 1, 2024, if a bulk-sending organization has an abuse complaint rate of 0.3% or higher, Google will automatically block all messages from that organization. Yahoo notes their enforcement will begin "in the first quarter of 2024". While Google and Yahoo are leading the way in early 2024, other email providers will likely follow suit.

WHO IS IMPACTED?
All Qualtrics Users

WHAT ARE WE DOING ABOUT IT?
Users will need to change any email addresses to use @mail.ucf.edu.

WHAT HAPPENS NEXT?
Users will need to change any email addresses to use @mail.ucf.edu.

WHAT DO I NEED TO DO?
Users will need to change any email addresses to use @mail.ucf.edu.
Posted Jan 09, 2024 - 12:04 EST
Update
WHAT IS HAPPENING?
Qualtrics is deprecating non-authenticated email addresses due to Google and Yahoo changing spam filtering rules. Mail.ucf.edu is the "official" UCF from email address to be used for all surveys and workflows.

Google and Yahoo aim to reduce the amount of spam emails their users receive and improve email security. To accomplish this, any bulk email sender will be subject to strict new requirements to avoid experiencing email deliverability issues.

Starting February 1, 2024, if a bulk-sending organization has an abuse complaint rate of 0.3% or higher, Google will automatically block all messages from that organization. Yahoo notes their enforcement will begin "in the first quarter of 2024". While Google and Yahoo are leading the way in early 2024, other email providers will likely follow suit.

WHO IS IMPACTED?
All Qualtrics Users

WHAT ARE WE DOING ABOUT IT?
We are currently investigating this issue.

WHAT HAPPENS NEXT?
Users will need to change any email addresses to use @mail.ucf.edu.

WHAT DO I NEED TO DO?
Users will need to change any email addresses to use @mail.ucf.edu.
Posted Jan 09, 2024 - 11:56 EST
Update
WHAT IS HAPPENING?
Qualtrics is deprecating non-authenticated email addresses due to Google and Yahoo changing spam filtering rules. Mail.ucf.edu is the "official" UCF from email address to be used for all surveys and workflows.

Google and Yahoo aim to reduce the amount of spam emails their users receive and improve email security. To accomplish this, any bulk email sender will be subject to strict new requirements to avoid experiencing email deliverability issues.

Starting February 1, 2024, if a bulk-sending organization has an abuse complaint rate of 0.3% or higher, Google will automatically block all messages from that organization. Yahoo notes their enforcement will begin "in the first quarter of 2024". While Google and Yahoo are leading the way in early 2024, other email providers will likely follow suit.

WHO IS IMPACTED?
All Qualtrics Users

WHAT ARE WE DOING ABOUT IT?
We are currently investigating this issue.

WHAT HAPPENS NEXT?
Users will need to change any email addresses to use @mail.ucf.edu.

WHAT DO I NEED TO DO?
Users will need to change any email addresses to use @mail.ucf.edu.
Posted Jan 09, 2024 - 11:55 EST
Identified
WHAT IS HAPPENING?
Qualtrics is deprecating non-authenticated email addresses due to Google and Yahoo changing spam filtering rules. Mail.ucf.edu is the "official" UCF from email address to be used for all surveys and workflows.

Google and Yahoo aim to reduce the amount of spam emails their users receive and improve email security. To accomplish this, any bulk email sender will be subject to strict new requirements to avoid experiencing email deliverability issues.

Starting February 1, 2024, if a bulk-sending organization has an abuse complaint rate of 0.3% or higher, Google will automatically block all messages from that organization. Yahoo notes their enforcement will begin "in the first quarter of 2024". While Google and Yahoo are leading the way in early 2024, other email providers will likely follow suit.

WHO IS IMPACTED?
All Qualtrics Users

WHAT ARE WE DOING ABOUT IT?
We are currently investigating this issue.

WHAT HAPPENS NEXT?
Users will need to change any email addresses to use @mail.ucf.edu.

WHAT DO I NEED TO DO?
Users will need to change any email addresses to use @mail.ucf.edu.
Posted Jan 09, 2024 - 11:28 EST
This incident affected: Data, Reporting & Analytics (Qualtrics).