What’s up, or down? The UCF Services Status Health Dashboard displays a real-time view of services that are working or possible current outages. Contact the UCF Support Center at 407-823-5117 for assistance or information about this site.
The issue was resolved as of approximately 12:15 PM. A system configuration in ServiceNow has been modified to allow ServiceNow to receive emails from svc_it_support@net.ucf.edu, any of its aliases, and any emails that redirect to svc_it_support@net.ucf.edu. All emails sent during the degradation were ingested by ServiceNow shortly after the issue was resolved. Thank you for your patience as the Service Management Solutions team actively worked to resolve the issue.
Posted Dec 08, 2025 - 14:51 EST
Investigating
WHAT IS HAPPENING? ServiceNow is experiencing an issue where emails sent to certain IT support addresses are not creating tickets as expected. Emails sent directly to the system address (ucf@service-now.com) are working. Any ticket emailed during this time may experience a slower response.
WHAT ARE WE DOING ABOUT IT? We are currently investigating this issue.
WHAT DO I NEED TO DO? To submit a ticket, please directly contact the Service Desk by calling 407-823-5117 or submitting a ticket directly in ServiceNow (ucf.service-now.com/ucfit) for support.
Posted Dec 08, 2025 - 10:54 EST
This incident affected: IT Service Delivery & Support (ServiceNow).