What’s up, or down? The UCF Services Status Health Dashboard displays a real-time view of services that are working or possible current outages. Contact the UCF Support Center at 407-823-5117 for assistance or information about this site.
There was an App Server resource limit hit with the amount of Advisement Audit, Enrollment, and Tuition Calc COBOL requests that were being invoked by students, advisors, and staff on the self service pages. This caused slowness in the environment because those processes were using up all other resources (like simple navigation around the new Campus Solutions center homepages and tiles). To remedy this, the Huron OCI partners have increased the limit of App Server processing instances on each server by 5 on the Student and Staff clusters. Two additional application servers were also added to the Student pool to handle load for registration activity this week.
Posted Aug 25, 2026 - 07:16 EDT
Update
WHAT IS HAPPENING? UCF IT is aware of an access concern in PeopleSoft Campus Solutions impacting all applicants, students, faculty, and staff. Anyone with these combination of roles maybe experiencing degraded access to the environment at this time.
WHO IS IMPACTED? All Applicants, Students, Faculty, and Staff connecting to Campus Solutions Self Service links through myUCF
WHAT ARE WE DOING ABOUT IT? We are currently investigating this issue.
WHAT HAPPENS NEXT? We will continue to send communications as we troubleshoot this problem.
WHAT DO I NEED TO DO? Stay updated on future service alerts through these platforms: - Review https://status.ucf.edu, where you can view service status and subscribe to email and text updates. - Main website: https://it.ucf.edu
Posted Aug 24, 2026 - 14:03 EDT
Investigating
WHAT IS HAPPENING? UCF IT is aware of an access concern in PeopleSoft Campus Solutions impacting all applicants, students, faculty, and staff. Anyone with these combination of roles maybe experiencing degraded access to the environment at this time.
WHO IS IMPACTED? All Applicants, Students, Faculty, and Staff connecting to Campus Solutions Self Service links through myUCF
WHAT ARE WE DOING ABOUT IT? We are currently investigating this issue.
WHAT HAPPENS NEXT? We will continue to send communications as we troubleshoot this problem.
WHAT DO I NEED TO DO? Stay updated on future service alerts through these platforms: - Review https://status.ucf.edu, where you can view service status and subscribe to email and text updates. - Main website: https://it.ucf.edu
Posted Aug 24, 2026 - 14:00 EDT
This incident affected: Student Information Systems (Campus Solutions).