University of Central Florida

Status
Dashboard

What’s up, or down? The UCF Services Status Health Dashboard displays a real-time view of services that are working or possible current outages. Contact the UCF Support Center at 407-823-5117 for assistance or information about this site.

PeopleSoft Campus Solutions is Unresponsive as of 5/12 1PM

Incident Report for UCF Service

Resolved

The issue is resolved. A new Pathlock rule was asked to be added to CSPROD by UCF IT's Information Security Office to help prevent authentication by invalid users. The rule was added out of order and it caused the sign on interruption you experienced this afternoon. It has since been removed and will be correctly be applied at another time outside of business hours.
Posted May 12, 2026 - 17:14 EDT

Identified

WHAT IS HAPPENING?
UCF IT is aware of an access concern in PeopleSoft Campus Solutions impacting applicants, students, staff, and faculty. Anyone with these combination of roles may be unable to access the options in Campus Solutions from myUCF.

WHO IS IMPACTED?
All Applicants, Students, Faculty, and Staff connecting to Student Self Service or Campus Solutions links through myUCF.

WHAT ARE WE DOING ABOUT IT?
We are currently investigating this issue.

WHAT HAPPENS NEXT?
We will continue to send communications as we troubleshoot this problem.

WHAT DO I NEED TO DO?
Stay updated on future service alerts through these platforms:
- Review https://status.ucf.edu, where you can view service status and subscribe to email and text updates.
- Main website: https://it.ucf.edu
Posted May 12, 2026 - 13:54 EDT
This incident affected: Student Information Systems (Campus Solutions).